Errore del controller su \Device\Harddisk0\D

Frequenti blocchi del PC

Dubbi, news e curiosità su PC e periferiche
Avatar utente
Rob
Site Admin
Site Admin
Messaggi: 19385
Iscritto il: 06/01/2008, 3:41
13
Località: 127.0.0.1
Umore:
Ha ringraziato: 5 volte
Sesso:

Messaggio

Da qualche giorno riscontro frequenti ed apparentemente casuali blocchi del PC, che avvengono nei momenti più disparati: durante l'esecuzione dei programmi, a riposo, in fase di avvio di Windows XP, subito dopo il caricamento del S.O.

Nella maggior parte dei casi si congela la schermata, puntatore del mouse compreso, con annessi strani effetti grafici a puntini:

Immagine

Il visualizzatore eventi di Windows (Start > Esegui... eventvwr): sotto la voce Sistema riporta moltissimi di questi errori:

Immagine

Il driver ha rilevato un errore del controller su \Device\Harddisk0\D.
Per ulteriori informazioni, consultare la Guida in linea e supporto tecnico all'indirizzo http://go.microsoft.com/fwlink/events.asp.



Preoccupato per la salute del mio disco fisso, un Western Digital Caviar da 250 GB EIDE, ho effettuato i test di verifica della casa produttrice, i Data Lifeguard Tools, che non hanno però rilevato errori.

Ho quindi controllato le temperature con SpeedFan, pare tutto regolare.

Ho poi effettuato anche alcuni test della RAM con Memtest86+ (CD avviabile) ed anche questi non hanno riscontrato nulla di anomalo (4 moduli per un totale di 2,5 GB di RAM). Tuttavia l'intera verifica (9 test) richiede molte ore, la effettuerò quando avrò modo.

Informandomi in rete ho scoperto che potrebbe trattarsi di un errore del controller EIDE o del cavetto difettoso. La seconda ipotesi mi sembra un po' improbabile perché per anni non mi ha mai dato problemi, quindi il prossimo tentativo che farò sarà quello di reinstallare i driver della scheda madre. Ho già provato senza successo a rimuovere da gestione periferiche tutti i canali EIDE, correttamente rilevati e reinstallati da Windows al successivo riavvio.

Aggiornerò questo topic quando avrò novità, intanto sono già 4 ore che il PC funziona normalmente. Cosa strana, considerato che verso le 20 di ieri sera non c'era verso di fargli completare il caricamento di Windows. Se intanto qualcuno ha qualche idea è ovviamente benvenuto. :sorriso2:
Avatar utente
Rob
Site Admin
Site Admin
Messaggi: 19385
Iscritto il: 06/01/2008, 3:41
13
Località: 127.0.0.1
Umore:
Ha ringraziato: 5 volte
Sesso:

Messaggio

Ho fatto girare per quasi 11 ore il Memtest: nessun errore rilevato. Direi che la memoria è a posto. :goccia3:
In realtà aveva completato tutti e 9 i test anche ieri, ma una sola volta. Ho eseguito quindi il check disk, ha trovato e corretto qualche errore minore (Pulite incongruenze minime sull'unità.). Per intanto non reinstallo ancora i driver della scheda madre, continuo a tenere d'occhio il visualizzatore eventi...
Avatar utente
Rob
Site Admin
Site Admin
Messaggi: 19385
Iscritto il: 06/01/2008, 3:41
13
Località: 127.0.0.1
Umore:
Ha ringraziato: 5 volte
Sesso:

Messaggio

Dopo quasi una settimana senza alcun blocco il PC poco fa mi si è piantato. Ho riavviato una volta con il tasto Reset e si è fermato sulla schermata nera poco prima dell'avvio di Windows. Ho spento del tutto, riacceso e stavolta l'avvio è andato a buon fine.
Subito ho controllato il Visualizzatore Eventi scoprendo che alcune ore fa, alle 19:20, si è verificato il solito errore del controller su \Device\Harddisk0\D.
Avatar utente
Rob
Site Admin
Site Admin
Messaggi: 19385
Iscritto il: 06/01/2008, 3:41
13
Località: 127.0.0.1
Umore:
Ha ringraziato: 5 volte
Sesso:

Messaggio

Aggiorno dicendo che finalmente ho risolto il problema sostituendo l'alimentatore.

Dopo le precedenti segnalazioni di errori è trascorso più di un mese di funzionamento apparentemente perfetto. A fine maggio, improvvisamente come sempre, il PC è tornato a congelarsi. Da lì, esaminando i dati di SpeedFan, ma anche direttamente dal BIOS, ho capito che era un problema di voltaggio insufficiente sulla linea dei 3.3 volt. Il valore oscillava da un massimo di 3.1 fino addirittura a 2.4 - 2.5 e questo malfunzionamento, quando il computer stava acceso per un periodo sufficientemente lungo, faceva salire rapidamente le temperature di CPU e chipset che si attestavano rispettivamente intorno ai 40° e 60°, come si vede dall'immagine di sinistra, ripresa pochi istanti prima di un nuovo blocco (a destra):

Immagine Immagine

Il sistema reggeva fino a circa 2.8 volt, al di sotto di quel valore, indipendentemente dalla temperatura raggiunta dalle componenti della scheda madre, cominciavo a vedere lo schermo sfarfallare, come se le lampade di retroilluminazione fossero difettose. Infatti inizialmente attribuivo la colpa di questo difetto al monitor. Dopo gli sfarfallamenti il PC si bloccava, a volte con a volte senza gli strani effetti grafici a puntini.

Appurato che la causa fosse l'alimentatore ho cercato di tirare avanti un altro po' per decidere il modello da acquistare, fino a quando, costretto a riavviare per l'ennesima volta, il PC non ha più voluto accendersi. O meglio, le ventole giravano ma rimaneva lo schermo nero. Rimosso il vecchio alimentatore per la sostituzione, ecco in che stato ho trovato il connettore di alimentazione della scheda madre (i terminali bruciacchiati sono proprio quelli della linea a 3.3 volt):

Immagine

Quando l'ho visto sono rimasto piuttosto sconcertato, si era annerita anche la presa della scheda madre, fortunatamente non irrimediabilmente. Dopo abbondanti spruzzi di spray puliscicontatti a secco G-20 ho lasciato asciugare con calma e sostituito il vecchio alimentatore (un Chieftec da 420 Watt) con un [b]CoolerMaster Silent Pro M500[/b] (500 W). PC riacceso, errori del controller su \Device\Harddisk0\D e sfarfallamenti vari spariti. Ecco i nuovi valori operativi della scheda madre, finalmente regolari. :cincin:


Immagine
Avatar utente
Fenice
Amministratrice
Amministratrice
Messaggi: 31358
Iscritto il: 06/01/2008, 14:53
13
Località: Prope Caput Mundi
Sesso:

Messaggio

Tutto è bene quel che finisce bene... La prossima volta saprai cosa fare. :bastard: Scherzo, si spera che non ci sia una prossima volta, ma se qualcuno avrà problemi analoghi (speriamo di no anche questo :occhi: ) la tua esperienza potrà essere utile. :ok: